maxbans not taken into accout

If your UnrealIRCd is up and running but you have a question about it, then use this forum.
(NOT for installation or connecting issues! Use the other forum instead.)

Moderator: Supporters

Post Reply
Webmaster78
Posts: 16
Joined: Sun Mar 15, 2020 2:06 am

maxbans not taken into accout

Post by Webmaster78 »

Hi there !

I want to increase the number of ban.
I am using UnrealIRCd-4.2.4.1.
No need to tell me that this is not the last version, nor that it is in principle no longer supported, it is my version that works perfectly, and I guess the people of the forum are not that beginners and will probably know the version I use.

I modified the unrealircd.conf file.
I rehashed it from my client irc who confirmed to me that it was well done.
I also restarted Unrealircd through SSH.
My changes are not taken into account!

There is always indicated on the server window: MAXLIST = b: 60, e: 60, I: 60 which is the default value!

However I added in the .conf file:
set {maxbans "200"; };
set {maxbanlength "7000"; };

Why is this not taken into account?
Any ideas ?

Thank you so much.
PeGaSuS
Posts: 62
Joined: Tue Jun 27, 2017 4:42 pm

Re: maxbans not taken into accout

Post by PeGaSuS »

As it has been stated in the support channel, UnrealIRCd 4 is no longer supported.

You should really upgrade to UnrealIRCd 5.

I've just added this on my unrealircd.conf, and after a rehash the values are updated:

Code: Select all

set {
	maxbans 200; /* Number of bans per channel */
	maxbanlength 60; /* Number of chars on the ban reason */
}
And I have this on my server window, using Hexchat:

Code: Select all

MAXLIST=b:200,e:200,I:200
Your maxbanlength is too high probably (7000 chars(?), when the maximum of IRC is 512).

Try with my settings and if doesn't work its probably because the settings doesn't exist for 4.x

Once again, upgrade your IRCd.
What goes around comes around!
Webmaster78
Posts: 16
Joined: Sun Mar 15, 2020 2:06 am

Re: maxbans not taken into accout

Post by Webmaster78 »

Thank you very much for your answer which gave me a lead that I had not thought of.

I simply reduced maxbanlength, changed it to 6800 instead of 7000 and it finally works!

The default values was 2048 for 60 bans. I did a proportional calculation for 200 bans, it gives 6800.

Now everything is working.


For maxbanlength, it's the sets the maximum amount of characters for all bans added up together, so basically this puts up a limit on the (semi-)maximum amount of memory all channel bans on a channel can take. The default is 2048 (bytes). With the default set::maxbans of 60 this allows 2048:60=34 characters per ban on average.

From : https://www.unrealircd.org/docs/Configu ... t::maxbans




Topic can be closed.
Post Reply