Problem to enable SASL

If your UnrealIRCd is up and running but you have a question about it, then use this forum.
(NOT for installation or connecting issues! Use the other forum instead.)

Moderator: Supporters

Post Reply
Webmaster78
Posts: 18
Joined: Sun Mar 15, 2020 2:06 am

Problem to enable SASL

Post by Webmaster78 »

I need to enable SASL on my irc.

When I do / quote CAP LS I have the answer ...
CAP LS: unrealircd.org/plaintext-policy=user=allow,oper=warn,server=deny unrealircd.org/link-security=2 extended-join chghost cap-notify userhost-in-names multi-prefix away-notify account -notify tls message-tags

I have respected, unless I'm mistaken, the indications of https://www.unrealircd.org/docs/SASL
In anope I edit the file modules.conf : module { name = "m_sasl" }.
In unreal I edit the file unrealircd.conf : set { sasl-server services.my.net; }; with my own.

Anope is well connected and active.

I have rehash.

What can be my problem ?
Syzop
UnrealIRCd head coder
Posts: 1972
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Re: Problem to enable SASL

Post by Syzop »

Although it may not be directly related to your problem, we noticed you are using an outdated UnrealIRCd version. So upgrade to UnrealIRCd 5 and also make sure you are using a recent anope version (2.0.7 or later).

SASL should then work out of the box once services are linked in. (And they are linked right? You can /WHOIS ChanServ ?)

If it doesn't work:
  • In UnrealIRCd both set::services-server or set::sasl-server should point to your services server.
  • In anope be sure to use the protocol module 'unreal4' (which is for unrealircd 4.x and higher) and not 'unreal' (which is for 3.2.x).
  • Obviously don't unload the sasl module in unrealircd or anope. By default the sasl module is loaded on both correctly though!
Post Reply