Since upgrading to 5.2.1.1 anope 2.0.3 doesn't connect

This forum is for everyone having trouble with linking two UnrealIRCd servers

Moderator: Supporters

Post Reply
s7ntax
Posts: 9
Joined: Tue Aug 04, 2020 10:23 pm

Since upgrading to 5.2.1.1 anope 2.0.3 doesn't connect

Post by s7ntax »

I upgraded unrealircd to 5.2.1.1 and i upgraded anope to 2.0.3 and services connects but then it immediately disconnects.

This is output in my irc

Code: Select all

irc.arpradio.com: Link services.arpradio.com -> irc.arpradio.com is now synced [secs: 0 recv: 1.455 sent: 5.78]
irc.arpradio.com: Lost server link to services.arpradio.com[s7ntax.uk]: Read error or connection closed.
I did a configtest on upgrading and I had to delete the block at line 444 that dealt with flood control and was no longer needed and I had to change the syntax on another line from ip to mask.

Here are my configs

services.conf

Code: Select all

uplink
{
        /*
         * The IP or hostname of the IRC server you wish to connect Services to.
         * Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
         *
         * NOTE: On some shell providers, this will not be an option.
         */
        host = "127.0.0.1"

        /*
         * Enable if Services should connect using IPv6.
         */
        ipv6 = no

        /*
         * Enable if Services should connect using SSL.
         * You must have an SSL module loaded for this to work.
         */
        ssl = no

        /*
         * The port to connect to.
         * The IRCd *MUST* be configured to listen on this port, and to accept
         * server connections.
         *
         * Refer to your IRCd documentation for how this is to be done.
         */
        port = 6900

        /*
         * The password to send to the IRC server for authentication.
         * This must match the link block on your IRCd.
         *
         * Refer to your IRCd documentation for more information on link blocks.
         */
        password = "**********************"
}
unrealircd.conf

Code: Select all

   
   listen {
        ip 127.0.0.1;
        port 6900;
        options {  serversonly; };
};

    
     link services.arpradio.com
{
        incoming {
                mask 127.0.0.1;
        };

        outgoing {
                bind-ip *; /* or explicitly an IP */
                hostname 127.0.0.1;
                port 6900;
                options {  };
        };

        password "*********************"; /* SSL fingerprint of other server */

        class servers;
};

    
     listen {
          ip 127.0.0.1;
          port 7000;
          options {
              serversonly;
          };
      };
      link services.arpradio.com {
          incoming {
              mask *@127.0.0.1;
          };
          password "******************";
          class servers;
      };
      ulines { services.localhost.net; };
DonTCry
Posts: 39
Joined: Mon Feb 06, 2012 6:01 pm
Contact:

Re: Since upgrading to 5.2.1.1 anope 2.0.3 doesn't connect

Post by DonTCry »

Check your unrealircd.conf
you have to link blocks for services and listen blocks
also your ulines is wrong
s7ntax
Posts: 9
Joined: Tue Aug 04, 2020 10:23 pm

Re: Since upgrading to 5.2.1.1 anope 2.0.3 doesn't connect

Post by s7ntax »

DonTCry wrote: Sat Aug 21, 2021 10:57 am Check your unrealircd.conf
you have to link blocks for services and listen blocks
I'm not sure what you mean.

I fixed the uline though.
k4be
Posts: 43
Joined: Sun Jan 09, 2005 12:19 pm
Location: Poland

Re: Since upgrading to 5.2.1.1 anope 2.0.3 doesn't connect

Post by k4be »

You have outgoing block for services in your unrealircd configuration? Services links are never outgoing. You also have two "services.arpradio.com" link blocks. But i don't think it's the cause of your problem. Maybe try starting services in debug mode (./bin/services -n -d=5) and see the detailed logs.
Please note that unrealircd 5 requires anope 2.0.7 or newer for all functions to work.
s7ntax
Posts: 9
Joined: Tue Aug 04, 2020 10:23 pm

Re: Since upgrading to 5.2.1.1 anope 2.0.3 doesn't connect

Post by s7ntax »

Ah, that was it. I upgraded anope to 2.0.10 and all is well. There may well be some 'mistakes' in my configs but nothing that is upsetting functionality so I will leave it as it is.

Thank you for your time.
Post Reply