Page 1 of 1

server name mismatch on link

Posted: Tue Dec 12, 2017 5:27 pm
by deadnyet
when trying to link to the hub, I get this error on the leaf side

Code: Select all

17:21 [mercyfuckers] !irc.mercyfuckers.org Outgoing link aborted to deadnetsmqxvz7j2.onion(unknown@xxxxx) (Outgoing connect from link block 'deadnetsmqxvz7j2.onion' but server introduced himself as 'deadnetsmqxvz7j2.onion'. Server name mismatch.) deadnetsmqxvz7j2.onion[@xxxxx]
Hub side link:

Code: Select all

link irc.mercyfuckers.org {
    incoming {
        mask xxx;
    };
    password "xxxxx" { spkifp; };
    leaf *;
    leaf-depth 0;
    class servers;
};
Leaf side:

Code: Select all

link deadnetsmqxvz7j2.onion {
    outgoing {
        hostname xxxxx;
        port 26019;
        options { ssl; autoconnect; };
    };
    password "xxxxx" { spkifp; };
    class servers;
};
running Unrealircd v4.0.17-rc1

Re: server name mismatch on link

Posted: Tue Dec 12, 2017 6:56 pm
by Syzop
Is the name in the me { } block on the hub, really deadnetsmqxvz7j2.onion?
It's saying there's a mismatch (although the error message may have an error in it :D)

Re: server name mismatch on link

Posted: Tue Dec 12, 2017 11:34 pm
by deadnyet
Syzop wrote:
Tue Dec 12, 2017 6:56 pm
Is the name in the me { } block on the hub, really deadnetsmqxvz7j2.onion?
It's saying there's a mismatch (although the error message may have an error in it :D)
yep!

Code: Select all

me {
        name "deadnetsmqxvz7j2.onion";
        info "Long live the Revolution! SSL only.";
        sid "2US";
};

Re: server name mismatch on link

Posted: Wed Dec 13, 2017 3:34 am
by deadnyet
remade my link config based off the wiki and it works now, feel free to close this thread :)

Re: server name mismatch on link

Posted: Wed Dec 13, 2017 8:04 am
by Syzop
Good!

I've found and fixed a bug in the development version, apparently a link block with link::outgoing but without link::incoming caused this confusing message (even though it's perfectly OK). The final fix will end up in UnrealIRCd 4.0.17.