PROBLEM LOADING THE SERVER.

These are old archives. They are kept for historic purposes only.
Post Reply
pixanim
Posts: 3
Joined: Sun Jan 09, 2005 9:29 pm
Location: Guaymas, Sonora, Mexico

PROBLEM LOADING THE SERVER.

Post by pixanim » Sun Jan 09, 2005 9:35 pm

I get the Angrywolf modules and others on internet. and i put the files on the folder where they should be go. and make the config exactly what say in texts. but when i want to load the server it crashes sayeing:

* Loading IRCd configuration ..
* unrealircd.conf:9: loadmodule modules/m_servlist.dll: failed to load: No se puede encontrar el módulo especificado.


[error] IRCd configuration failed to load

and my config is:
loadmodule "modules/commands.dll";
loadmodule "modules/cloak.dll";
loadmodule "modules/m_antidccbug.dll";
loadmodule "modules/m_jumpserver.dll";
loadmodule "modules/m_ircops.dll";
loadmodule "modules/m_staff.dll";
loadmodule "modules/m_nocodes.dll";
loadmodule "modules/m_privdeaf.dll";
loadmodule "modules/m_servlist.dll";
loadmodule "modules/m_uline.dll";
loadmodule "modules/netadmins.dll";
loadmodule "modules/nocolorumode.dll";
loadmodule "modules/operjoin.dll";
loadmodule "modules/operpasswd.dll";
loadmodule "modules/topicbadwords.dll";
loadmodule "modules/commandsno.dll";
loadmodule "modules/hideserver.dll";
loadmodule "modules/joinpartsno.dll";
loadmodule "modules/m_sendraw.dll";

everything is like it should be but don't load the server :(

i changed the line putting another module and exactly on line 9. says it can't load the module on that line.

Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Post by Stealth » Sun Jan 09, 2005 9:42 pm

What does "No se puede encontrar el módulo especificado" mean in english?

pixanim
Posts: 3
Joined: Sun Jan 09, 2005 9:29 pm
Location: Guaymas, Sonora, Mexico

Post by pixanim » Sun Jan 09, 2005 9:45 pm

It is not possible to find the specified module.

Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Post by Stealth » Sun Jan 09, 2005 10:34 pm

Where did you download the module DLL's from?

pixanim
Posts: 3
Joined: Sun Jan 09, 2005 9:29 pm
Location: Guaymas, Sonora, Mexico

Post by pixanim » Sun Jan 09, 2005 10:39 pm


Stealth
Head of Support
Posts: 2086
Joined: Tue Jun 15, 2004 8:50 pm
Location: Chino Hills, CA, US
Contact:

Post by Stealth » Sun Jan 09, 2005 11:17 pm

AngryWolf doesnt have DLL's on his site, because he doesnt use Windows at all.

If you need modules already compiled for Windows, go to http://www.x-tab.org/~ircd/

Paradox

Yes, AngryWorlf does have a list of DLL for his modules

Post by Paradox » Fri Jan 06, 2006 9:02 pm

Infact he does, compiled by a few people who helped him out with it. But I get the excact same error... using the DLL's moved to "modules/module.dll" etc. and the loadmodule with the same dir & filename in the config, but still does'nt load them and sends out errors to service.log

And...

Not only with the DLL's compiled from AngryWolf's mods, but even the the modules listed on http://www.x-tab.org/~ircd/ for download shoot out the same errors.

Solutech
Posts: 296
Joined: Thu Mar 18, 2004 11:38 pm

Post by Solutech » Fri Jan 06, 2006 9:08 pm

Are you using modules compiled for the correct unreal version ?
Yawn. So there's yet another "if the user clicks the button, they're infected" exploit. Why is this news? We already know users are idiots.

Post Reply