Error loading modules

These are old archives. They are kept for historic purposes only.
Post Reply
Itsme-HcK
Posts: 20
Joined: Tue Jan 04, 2005 5:28 pm
Location: Nijmegen
Contact:

Error loading modules

Post by Itsme-HcK » Sun Mar 20, 2005 2:58 pm

Whatever I try, the server NEVER finds the modules, but I am sure they are there.

Does anyone know how to fix it?

This is the config:

loadmodule "modules/commands.dll";
loadmodule "modules/cloak.dll";
loadmodule "modules/m_banlink.dll";
loadmodule "modules/m_chgswhois.dll";
loadmodule "modules/m_getinfo.dll";
loadmodule "modules/m_killprotect.dll";

And these the errors:

(15:57:23) -irc2.bramd.nl- *** Notice -- unrealircd.conf:43: loadmodule modules/m_killprotect.dll: failed to load: Kan opgegeven module niet vinden.
(15:57:23) -irc2.bramd.nl- *** Notice -- error: IRCd configuration failed to load

"Kan opgegeven module niet vinden" means "Can't find that file!1!"

Syzop
UnrealIRCd head coder
Posts: 1955
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Post by Syzop » Sun Mar 20, 2005 3:19 pm

Does it also happen with my modules? (link) or not?
If it doesn't then it's because these modules were compiled with a different Visual Studio version than the official unreal, in which case you could well be missing the required runtime library (.dll)... I think there's something on Stealth's site about that?
Last edited by Syzop on Sun Mar 20, 2005 3:21 pm, edited 1 time in total.

Itsme-HcK
Posts: 20
Joined: Tue Jan 04, 2005 5:28 pm
Location: Nijmegen
Contact:

Post by Itsme-HcK » Sun Mar 20, 2005 3:21 pm

Yeah, I just found it two minutes ago. :)

Thnx anyway.

Post Reply