Anti random module help

These are old archives. They are kept for historic purposes only.
Post Reply
White_Magic
Posts: 267
Joined: Tue Jan 18, 2005 3:24 pm
Location: Scotland - United Kingdom

Anti random module help

Post by White_Magic » Thu Aug 04, 2005 12:19 pm

ive loaded the anti random module, no problems,
when i add the set to the conf thou i get a set directive error, been thru the faq to try n sovle it and i still truly have no idea wots wrong

Code: Select all

set {
antirandom {
             threshold 5;
             ban-action gzline;
             ban-time 4h;
             ban-reason "You look like a bot. Be sure to fill in your nick/ident/realname properly.";
              fullstatus-on-load yes;
              show-failedconnects yes;
              except-hosts {         
              };
   };
};
:) thanks
i spend 4 hrs a day gaming and 14hrs on irc, for 5days a week, im not an addict :D

Syzop
UnrealIRCd head coder
Posts: 1957
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Post by Syzop » Fri Aug 05, 2005 9:51 pm

What you pasted is (and works) just fine :p.

Do you have a loadmodule line for the antirandom module?

What's the exact error you get?

White_Magic
Posts: 267
Joined: Tue Jan 18, 2005 3:24 pm
Location: Scotland - United Kingdom

Post by White_Magic » Sat Aug 06, 2005 5:42 pm

[18:39] -Server- *** antirandom - v0.1.1 (Randomness detector) [3RD]


[18:39] -Server- *** Notice -- Loading IRCd configuration ..
-
[18:39] -Server- *** Notice -- error: doc/server.settings:30: unknown directive set::antirandom
-
[18:39] -Server- *** Notice -- error: 1 errors encountered
-
[18:39] -Server- *** Notice -- error: IRCd configuration failed to pass testing

----
loadmodule "src/modules/antirandom.so";

from the conf file
i spend 4 hrs a day gaming and 14hrs on irc, for 5days a week, im not an addict :D

Syzop
UnrealIRCd head coder
Posts: 1957
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Post by Syzop » Sat Aug 06, 2005 6:59 pm

Ah ok, that seems an old version of antirandom.
There was an error on the unrealircd.com page (until) a week or so ago, serving v0.1.1 instead of v1.0/v1.1... Perhaps that's why :)

Post Reply