Problem loading module compiled with VC8

These are old archives. They are kept for historic purposes only.
Post Reply
Posts: 2
Joined: Sun Jun 24, 2007 7:33 pm

Problem loading module compiled with VC8

Post by VBStrider »

I need help, I tried adding the module textban ( to UnrealIRCd 3.2.6 and now UnrealIRCd will not start. The error I get is as follows: "* unrealircd.conf:42: loadmodule modules/textban.dll: failed to load: The specified module could not be found.".

I compiled the module myself using VC8 and the guide located in doc\compiling_win32.txt. I then copied the .dll to the UnrealIRCd that I installed using the installer (I downloaded and compiled a separate copy of UnrealIRCd so that I could compile the module). The guide said that once compiled, the module should work on other unreal installations.

I have tried putting MSVCR80.dll into the UnrealIRCd installation folder, but then I get a Microsoft Visual C++ Runtime Library error as follows: "An application has made an attempt to load the C runtime library incorrectly." and UnrealIRCd reports this error: "* unrealircd.conf:42: loadmodule modules/textban.dll: failed to load: A dynamic link library (DLL) initialization routine failed." but the guide said that VC8 should work since Unreal3.2.5.

The reason I wish to compile the module myself is that I want to create my own modules for UnrealIRCd, and so the first thing to take care of is making sure that I actually can compile a module.

Official supporter
Posts: 1180
Joined: Wed May 03, 2006 7:09 pm
Location: United Kingdom

Post by Jobe »

Stealth wrote:If you'd use the search feature, you'd find many posts about this.

They all say pretty much the same thing: MSVS 8 is NOT supported
I think that pretty much covers it.
Posts: 2
Joined: Sun Jun 24, 2007 7:33 pm

Post by VBStrider »

Compatible compilers:
cygwin NOT supported. Will not work. Should be no reason to use this anyway.
msvc 6.x Microsoft Visual Studio 6 does not work, this compiler is too old.
msvc 7.x Microsoft Visual Studio 7.x (.NET) will work just fine
msvc 8.x Microsoft Visual Studio 8.x (.NET 2005), including the free kit,
should work fine (since Unreal3.2.5).
doc/compiling_win32.txt might need to be updated then.

I'll try compiling with msvc 7.1.

I compiled Unreal3.2.6 and the module using msvc 7.1 and it works. Thank you for the help :).

Posts: 338
Joined: Sun Jul 08, 2007 7:44 am
Location: The Netherlands

Post by Casper »


I've got a small problem. In the files is that you should use MSVC 7.x or MSVC 8.x . I know by now that I can't use MSVC 8.x. So, I'm searching for MSVC 7.x now for some time now. I was wondering, can anyone give me the link to where I can download it? (I know, I'm a n00b, I guess that's just me...) If I follow the link in compiling_win32.txt ( ), I get the following message: "The Visual C++ Toolkit 2003 has been replaced by Visual C++ 2005 Express Edition.", which is MSVC 8.x

Thanks in advance!

Posts: 72
Joined: Tue Oct 04, 2005 6:32 am
Location: ByNets@Belarus

Post by wax »

unrealircd compiling by msvs8 perfectly. If not compiling module - must be asked people who write it to fix trouble.
Posts: 1
Joined: Sat Oct 06, 2007 6:17 am

Re: Problem loading module compiled with VC8

Post by FriendMaster »

I long tried to compel to work modules of compiled on VC 8 under Unreal and got a result.
Attention: On a machine where costs Unreal Framework 2 must be set
Step by step:
1. We get a source code
2. We compile
3. We find the file of wircd.exe.manifest in a folder where wircd.exe lies
4. We copy wircd.exe.manifest on a working server
Further we compile your modules (VC) and test

All secret in transition with VC 2003 -> VC 2005
to add Framework 2, wircd.exe.manifest on a server

Post Reply