[cgi irc] No luck with the module and 3.2.1

These are old archives. They are kept for historic purposes only.
Post Reply
yutt
Posts: 5
Joined: Sat Jun 26, 2004 11:28 pm

[cgi irc] No luck with the module and 3.2.1

Post by yutt » Thu Jul 08, 2004 3:55 pm

I recently added the Angry Wolf's cgi:irc module to my Unreal configuration, but it doesn't appear to have any affect. I am hoping it is a simple configuration error.

It compiled without a hitch (thanks Wolf), and has been added as an include to my unrealircd.conf. There is also some additional configuration necessary, which to the best of my knowledge, I have done correctly.

Code: Select all

set {
        cgiirc-host 127.0.0.1;
};

except ban { mask *@192.168.0.31; };
except throttle { mask *@192.168.0.31; };

except tkl { type gline; mask *@192.168.0.31; };
except tkl { type gzline; mask *@192.168.0.31; };
except tkl { type shun; mask *@192.168.0.31; };
Does anyone else have experience configuring this module? The web server hosting cgi:irc is the same machine as the UnrealIRCD server, hence the 127.0.0.1. The 192.168.0.31 is the machine's internal IP address, which appears to be what the IRC server is receiving. I have tried switching everything to 127.0.0.1, and everything to 192.168.0.31 with the same results.

The user can connect for about 30 seconds, send and receive messages, then they disconnect for no apparent reason.

AngryWolf
Posts: 554
Joined: Sat Mar 06, 2004 10:53 am
Location: Hungary
Contact:

Post by AngryWolf » Thu Jul 08, 2004 4:31 pm

Hi,

First of all, I'm thinking of a documentation rewrite, because it isn't as understandable as it seemed to be at the first time. :)

My first question is: are you sure you applied the patch in cgi:irc correctly? Because if the client still cannot send IPs/hostnames as passwords, you won't notice any effects.

Secondly, if cgi:irc and Unreal are on the same host, be sure to set both default_server in cgiirc.config and set::cgiirc-host to localhost/127.0.0.1 (or an other IP address that your computer have, ie. 192.168.0.31), and the address you choose must be the same in both directives and in the except * blocks.

If you are unsure, temporarely turn off the security setting in unrealircd.conf by commenting out set::cgiirc-host, then you can test whether the client is patched well.

"no apparent reason": well, then what reason do you get? EOF from the client or what? I'm unable to help without seeing the exact error message. (By the way, if you want to report a bug, you know where to do it.)

AngryWolf
Posts: 554
Joined: Sat Mar 06, 2004 10:53 am
Location: Hungary
Contact:

Post by AngryWolf » Thu Jul 08, 2004 5:00 pm

Oh, sorry, I've just realized that you also have to add "realhost_as_password = 1" in the cgiirc.config file. Will add this information into the new documentation. :)

AngryWolf
Posts: 554
Joined: Sat Mar 06, 2004 10:53 am
Location: Hungary
Contact:

Post by AngryWolf » Thu Jul 08, 2004 6:52 pm

As I promised, a new documentation is done and available in version 1.15. If you still have problems or questions, I'm open to hear them.

yutt
Posts: 5
Joined: Sat Jun 26, 2004 11:28 pm

Post by yutt » Fri Jul 09, 2004 2:11 am

The new setting you gave me definitely made a difference, though I am not sure if it's an improvement. ;)

Now when I try to connect with cgiirc, I immediately get:

Code: Select all

*** An error occured: Connecting to IRC: Connection refused
Disconnected
Not only do I get this error, but my Unreal process dies. After restarting my server and trying a couple more times I get it again.

Have you ever seen this? I will double check all of my settings, but the whole server crashing surprised me.

Also, I haven't had a chance to check your new documentation, but I would suggest adding a section on how to apply the .diff patch to cgi:irc. All of your other steps were fairly comprehensive, but I had never applied a source patch before, so it was a bit of Googling before I learned how. :)

AngryWolf
Posts: 554
Joined: Sat Mar 06, 2004 10:53 am
Location: Hungary
Contact:

Post by AngryWolf » Fri Jul 09, 2004 8:37 am

It's okay, the new documentation includes that section about the .diff patch. (Anyway it's very honourable that you used Google to find out how to apply it.) I have no idea what happened with http://www.angrywolf.org, but I couldn't connect to it either. I'm going to contact the web server administrator shortly. Till then try one of my mirror servers:

www.angrywolf.za.net
angrywolf.smart-host.us
angrywolf.uw.hu
angrywolf.fw.hu

The new setting is not an improvement, it's just the patch that requires it to be set to a true value.

As for the crash: it must be a bug, and I haven't seen this, so please follow the instructions of this page and let me fix it.

Post Reply