Page 1 of 1

the 'No Color Umode' module

Posted: Sat Jul 09, 2011 10:51 pm
by joshuac
So I'm assuming I installed the module: nocolorumode.c correctly because users are able to put on the usermode +c
However, when colors are used it doesn't appear to be stripped.

1. Is this a known issue.

2. Does the IRCd process require a restart (I'm assuming not because upon rehashing users are able to put usermode +c on so it theoretically work.

__________

Extra info: (in case it helps)
Unrealircd --> 3.2.8.1 (module on http://www.unrealircd.com/modules/view/6 is listed as UnrealIRCD 3.2.x so that shouldn't be an issue)

Greatly appreciate it :)

Re: the 'No Color Umode' module

Posted: Sun Jul 10, 2011 1:41 pm
by Jobe1986
As I understand the description, this mode ONLY applies to private PRIVSMSG and NOTICE sent to the user. It does not apply to channel PRIVMSG and NOTICE that are sent to the user. Although I may be wrong about that.

Re: the 'No Color Umode' module

Posted: Sun Jul 10, 2011 2:54 pm
by joshuac
ah I didn't try that.

*checks*

yep. Well don't I feel like an idiot. Even more so because I read the README and I remember seeing the words PRIVMSG and NOTICE
:roll:

Thanks, anyway though :) Now to break the bad news to the two users (who happen to be opers) that were really wanting a color stripping usermode. :lol:

Re: the 'No Color Umode' module

Posted: Sun Jul 10, 2011 6:56 pm
by katsklaw
Uhm, Chanmode +c doesn't work for you?

Re: the 'No Color Umode' module

Posted: Sun Jul 10, 2011 8:08 pm
by SpaceDoG
I believe it's chanmode +S to strip the colors and allow the message to pass. +c blocks the message.