Anope Would not Link with Unreal

This forum is for everyone having trouble with linking two UnrealIRCd servers

Moderator: Supporters

Post Reply
Serkons
Posts: 1
Joined: Tue Oct 18, 2022 11:18 pm

Anope Would not Link with Unreal

Post by Serkons »

Sorry if I'm wrong here but I can't anope with my unrealircd link. He always says this:
[Oct 18 23:22:57 2022] Lost connection from uplink #1 (xx.xxx.xxx.xx:6000)
[Oct 18 23:22:57 2022] Check that you are not connecting Anope to an SSL enabled port without configuring SSL in Anope (or vice versa)
This is the link block etc. that something is wrong but I just can't find anything? maybe you can help me there? I don't have SSL enabled on this port.
Both Config Parts located on diferent machines
Unrealircd.conf part Link block and ulines: (Unrealircd Windows Server)

Code: Select all

link services.igamerpg.de {
    incoming {
        mask *;
    };
    outgoing {
        bind-ip *; /* or explicitly an IP if you have a shell provider, as mentioned in step 1 */
        hostname xx.xxx.xxx.xx; /*  or if 'beta.test.net' does not exist then you can use an IP or something like 'beta.dyndns.org' */
        port 6000; /* the special SSL server port we opened up earlier */
        options { };
    };
    password "xxxxx";
    class servers;
};

/* U-lines give other servers (even) more power/commands.
 * If you use services you must add them here.
 * NEVER put the name of an UnrealIRCd server here!!!
 */
ulines {
	services.igamerpg.de;
}

Services.conf section uplink (Ubuntu VM in Virtualbox):

Code: Select all

uplink
{
	/*
	 * The IP or hostname of the IRC server you wish to connect Services to.
	 * Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
	 *
	 * NOTE: On some shell providers, this will not be an option.
	 */
	host = "xx.xxx.xxx.xx"

	/*
	 * Enable if Services should connect using IPv6.
	 */
	ipv6 = no

	/*
	 * Enable if Services should connect using SSL.
	 * You must have an SSL module loaded for this to work.
	 */
	ssl = no

	/*
	 * The port to connect to.
	 * The IRCd *MUST* be configured to listen on this port, and to accept
	 * server connections.
	 *
	 * Refer to your IRCd documentation for how this is to be done.
	 */
	port = 6000

	/*
	 * The password to send to the IRC server for authentication.
	 * This must match the link block on your IRCd.
	 *
	 * Refer to your IRCd documentation for more information on link blocks.
	 */
	password = "xxxx"
}
So what's wrong with it?
Thanks for help!
Post Reply