irccloud not recognized as webirc-users

If your UnrealIRCd is up and running but you have a question about it, then use this forum.
(NOT for installation or connecting issues! Use the other forum instead.)

Moderator: Supporters

Post Reply
CrazyCat
Posts: 185
Joined: Thu Apr 28, 2005 1:05 pm
Location: France
Contact:

irccloud not recognized as webirc-users

Post by CrazyCat »

Hi there,

I've a strange trouble with my unrealircd: mibbit users are well recognized as wenirc-users but irccloud aren't.

Code: Select all

# connect from mibbit page
irc.zeolia.net: connect.REMOTE_CLIENT_CONNECT [info] Client connecting: GatoLoco (Mibbit@this.is.my.ip) [this.is.my.ip] [vhost: cloaked.my.ip] [secure: TLSv1.2-ECDHE-RSA-AES256-GCM-SHA384] [country: FR] [reputation: 10000] [security-groups: known-users,webirc-users,tls-and-known-users]
# connect from irccloud
irc.zeolia.net: connect.REMOTE_CLIENT_CONNECT [info] Client connecting: GatoLoco (uid339xx@lymington.irccloud.com) [5.254.36.59] [vhost: zeolia-626A1FC6.irccloud.com] [secure: TLSv1.2-ECDHE-RSA-CHACHA20-POLY1305] [country: US] [reputation: 7420] [security-groups: known-users,tls-and-known-users,tls-users]
My webirc.conf is:

Code: Select all

// -- Mibbit --
webirc { mask 207.192.75.252; password "********"; };
webirc { mask 78.129.202.38; password "********"; };
webirc { mask 109.169.29.95; password "********"; };
except throttle { mask 207.192.75.252; };
except throttle { mask 78.129.202.38; };
except throttle { mask 109.169.29.95; };
// -- /Mibbit --

// -- irccloud --
webirc { mask 5.254.36.105; };
webirc { mask 5.254.36.58; };
webirc { mask 5.254.36.59; };
webirc { mask 5.254.36.60; };
webirc { mask 5.254.36.61; };
webirc { mask 5.254.36.62; };
except throttle { mask 5.254.36.105; };
except throttle { mask 5.254.36.58; };
except throttle { mask 5.254.36.59; };
except throttle { mask 5.254.36.60; };
except throttle { mask 5.254.36.61; };
except throttle { mask 5.254.36.62; };
// -- /irccloud --
I can't find anywhere how to set a password for irccloud. I've tried adding password ""; to the webirc blocks but it doesn't work.

Any idea or suggestion ?
PeGaSuS
Official supporter
Posts: 84
Joined: Tue Jun 27, 2017 4:42 pm

Re: irccloud not recognized as webirc-users

Post by PeGaSuS »

AFAIK, IRCCloud doesn't use webirc, so that behaviour is expected.

Basically IRCCloud acts like a BNC service on steroids. :D

As stated by them:

Code: Select all

Identifying users
Each user can be uniquely identified for the purpose of bans, etc. by their ident-verified username, in the form [u|s]id[UID] (eg: uid123 for a free user or sid456 for a paid subscriber). Users are unable to change their user IDs.

IPv6 support
On IPv6, each IRCCloud user connects from their own unique IPv6 address, with forward and reverse DNS entries that look like id-[UID].[POOL_HOST], eg: id-1234.highgate.irccloud.com

If your network supports IPv6 connections, we'll detect any AAAA records exposed in DNS, and favour those by default. This allows us to assign each user a unique IPv6 address, mapped from their user ID, e.g. 2001:67c:2f08:1::[UID_IN_HEX]

This is the preferred way to allow IRCCloud support, since each IRCCloud user connects from their own unique address.

In case of v6 failure, please make sure there are sensible session limits of the v4 IPs too, as IRCCloud will retry connections using IPv4 if IPv6 fails.
You can check it yourself on https://www.irccloud.com/networks.

Hope thhis helps.
What goes around comes around!
CrazyCat
Posts: 185
Joined: Thu Apr 28, 2005 1:05 pm
Location: France
Contact:

Re: irccloud not recognized as webirc-users

Post by CrazyCat »

Ok, I understand now.
So no need of the webirc settings, just the allow block to ensure more than 3 irccloud users can come.

Thank PeGaSuS
PeGaSuS
Official supporter
Posts: 84
Joined: Tue Jun 27, 2017 4:42 pm

Re: irccloud not recognized as webirc-users

Post by PeGaSuS »

CrazyCat wrote: Sat Nov 19, 2022 7:59 pm Ok, I understand now.
So no need of the webirc settings, just the allow block to ensure more than 3 irccloud users can come.

Thank PeGaSuS
Yes, exactly that. :)

Also, try to exempt IRCCloud from antirandom because I've had issues in the past.

IRCCloud reconnects with the nick you've disconnected with, which may be something like Guest-1235 (yes, that's a weird behaviour) and that might trigger antirandom on special cases.

Glad I've been of help :D
What goes around comes around!
Post Reply