Auditorium - Unable to install it. '_hook_error_incompatible();'

Looking for a module? Or want to see one converted to 6.x?

Moderator: Supporters

Post Reply
dktmb
Posts: 3
Joined: Wed May 24, 2023 10:23 pm

Auditorium - Unable to install it. '_hook_error_incompatible();'

Post by dktmb »

Hi ! o/

I was trying to install auditorium frome module manager in vain...
I'm on the last release of Unreal and try it with ./unrealircd module install third/auditorium

It give it to me this error :

Code: Select all

/unrealircd-6.1.1.1/include/modules.h:2457:9: error: call to ‘_hook_error_incompatible’ declared with attribute error: Incompatible hook function. Check arguments and return type of function.
 2457 |         _hook_error_incompatible();
      |         ^~~~~~~~~~~~~~~~~~~~~~~~~~
Any sugestion would be appreciated : )
Thanks !
CrazyCat
Posts: 213
Joined: Thu Apr 28, 2005 1:05 pm
Location: France
Contact:

Re: Auditorium - Unable to install it. '_hook_error_incompatible();'

Post by CrazyCat »

I can confirm: tested on raspbian with unreal 6.1.0: works like a charm
With 6.1.1.1 same error
Gottem
UnrealIRCd coder
Posts: 192
Joined: Fri Aug 19, 2016 5:26 pm
Location: NL

Re: Auditorium - Unable to install it. '_hook_error_incompatible();'

Post by Gottem »

Apparently the module API has changed again, I've updated the module so it should work fine now. =]
If you like my modules, pls consider donating (credit card or iDEAL, use the custom job fee option in my shop) ;];]
CrazyCat
Posts: 213
Joined: Thu Apr 28, 2005 1:05 pm
Location: France
Contact:

Re: Auditorium - Unable to install it. '_hook_error_incompatible();'

Post by CrazyCat »

Tested: compilation successful, thx Gottem
Post Reply