./config error

If you hit any installation issues or cannot connect to your freshly installed UnrealIRCd then this forum is for you.

Moderator: Supporters

Post Reply
slimdesi
Posts: 3
Joined: Sat May 11, 2024 1:24 pm

./config error

Post by slimdesi »

Hi there Guys,

Got this error running the command ./Config

Im on centos-8-x86_64 on a vps .. tried installing the tools on it .. but cant really get it done. please advise


Your system does not have the required tools installed to build UnrealIRCd.
Please check https://www.unrealircd.org/docs/Installing_from_source
and install the required tools listed under 'Prerequisites'.
After that, you can run ./Config again
Valware
Official supporter
Posts: 39
Joined: Wed Mar 31, 2021 3:17 am
Location: Internet
Contact:

Re: ./config error

Post by Valware »

Please check https://www.unrealircd.org/docs/Installing_from_source
and install the required tools listed under 'Prerequisites'.
After that, you can run ./Config again
Got an idea for a module? Don't be shy! Come talk to me on #unreal-support
Like the support I provide? Consider supporting me with a donation.
slimdesi
Posts: 3
Joined: Sat May 11, 2024 1:24 pm

Re: ./config error

Post by slimdesi »

ive been trying to install on centos but it doesnt help at all ... im not that good at it .. normally installed unreal without problems ... can it be coz of the OS
CrazyCat
Posts: 219
Joined: Thu Apr 28, 2005 1:05 pm
Location: France
Contact:

Re: ./config error

Post by CrazyCat »

Did you do (as root):

Code: Select all

yum install make gcc openssl openssl-devel
The full package list is:
  • coreutils
  • gzip
  • pkgconf-pkg-config
  • gcc
  • make
  • curl
  • openssl
  • openssl-devel
  • pcre2
  • pcre2-devel
  • c-ares
  • c-ares-devel
  • libargon2-devel
Post Reply