can't remove spamfilter

These are old archives. They are kept for historic purposes only.
Post Reply
Posts: 1
Joined: Thu Mar 28, 2013 10:24 pm

can't remove spamfilter

Post by bloodymary »

got 2 lines, can't remove them

f cp block 0 27 864000 Server_Advertisement _is_NOT_Allowed_in_Chilag_Network_ irc.Chilag.Net *i*r*c*
f cp block 0 27 864000 Server_Advertisement _is_NOT_Allowed_in_Chilag_Network irc.Chilag.Net irc\..*\..*

i tried the RAW, based on older questions here, nothing worked
please help :(
Posts: 21
Joined: Fri Feb 15, 2013 9:42 pm
Location: Greece

Re: can't remove spamfilter

Post by westor »

try these maybe work.

/spamfilter del cp block - Server_Advertisement_is_NOT_Allowed_in_Chilag_Network irc.Chilag.Net irc\..*\..*
/spamfilter del cp block - Server_Advertisement _is_NOT_Allowed_in_Chilag_Network_ irc.Chilag.Net *i*r*c*
I Would Like To Kiss You But I Cant Tell Me Why Not My BaBy ? ? ?
UnrealIRCd head coder
Posts: 1994
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl

Re: can't remove spamfilter

Post by Syzop »

You made the 'NOT' part bold, I presume that was intentional and on IRC that word was also in bold?

Method 1:
If you use mIRC then hold down CTRL when copying the reason field with your mouse (from the STATS output), that way you would include hidden codes such as bold. Then paste it in your spamfilter del line... For some other clients this method may also work.

When you specify a condition in delete (such as the 'reason' field), the IRCd will compare them byte-for-byte, so even if there's a bold code in it (or double-bold code, which you won't even see) then it needs to be specified exactly like that.

Method 2 (much easier):
When deleting you don't have to specify the reason field, so to keep it simple I would advise you to just use:

/spamfilter del cp block - - irc\..*\..*
/spamfilter del cp block - - *i*r*c*

(See '/HELPOP ?SPAMFILTER'. It isn't really explained, but it is shown in the 2nd last example there)
Post Reply