Linking Problem - No autoconnect

This forum is for everyone having trouble with linking two UnrealIRCd servers

Moderator: Supporters

Post Reply
DJFelipe
Posts: 3
Joined: Sun Mar 11, 2018 12:55 am

Linking Problem - No autoconnect

Post by DJFelipe » Sun Mar 11, 2018 1:06 am

Hey Guys,

i want to upgrade my Unreal3 Network to the current version (4.0.17) but i have some problems with the new branch. I imported my old configurations and let unreal convert it to the new schema but anytime i start or wait, the ircd doesnt want to autoconnect to my Hub1 server.
If i manual start the link process, its doing it well.

Leaf Link Config:

Code: Select all

class           servers
{
        pingfreq 60;
        maxclients 10;
        sendq 5M;
        connfreq 30;
};
link Hub1.MyNetwork.local {
        outgoing {
                bind-ip *;
                hostname 138.152.134.224;
                port 3001;
                options {
                        ssl;
                        autoconnect 60;
                };
        };
        password "linkylinkythereitgoes";
        class servers;
};
Even if i use only 'autoconnect;' without a number behind it, the leaf doesnt try to establish a connection to the Hub.

I also tried to use the DEBUGMODE from config.h but without success.. Nothing usefull was placed in the debug.log file. :(

DonTCry
Posts: 19
Joined: Mon Feb 06, 2012 6:01 pm
Contact:

Re: Linking Problem - No autoconnect

Post by DonTCry » Sun Mar 11, 2018 7:10 am

try:

options { ssl; autoconnect; };

DJFelipe
Posts: 3
Joined: Sun Mar 11, 2018 12:55 am

Re: Linking Problem - No autoconnect

Post by DJFelipe » Sun Mar 11, 2018 7:17 am

Doesnt work.... :?

DJFelipe
Posts: 3
Joined: Sun Mar 11, 2018 12:55 am

Re: Linking Problem - No autoconnect

Post by DJFelipe » Fri Mar 16, 2018 2:26 am

Seriously? Nobody?

Syzop
UnrealIRCd head coder
Posts: 1806
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Re: Linking Problem - No autoconnect

Post by Syzop » Sat Apr 07, 2018 7:05 am

Strange. Your config looks fine to me (without the number, that is). There are many people (possibly everyone with a network) using SSL and autoconnect and this is the first time I hear about a possible issue.
If you are still experiencing the issue and you think it's a bug, then feel free to report on https://bugs.unrealircd.org with as much details as you can (you can also mark the bug report as 'private' if it contains sensitive information)

Post Reply