[REQ] Forcing the use of encrypted communication

Need a module converted from 3.2.x to UnrealIRCd 4? Or looking for a certain module? Ask here.

Moderators: Gottem, Supporters

Post Reply
HeXiLeD
Posts: 31
Joined: Mon Jan 16, 2017 8:07 pm
Location: online

[REQ] Forcing the use of encrypted communication

Post by HeXiLeD » Thu Jun 07, 2018 9:29 pm

This is an idea that I have been pursuing for a long time.

Forcing the use of encrypted communication by OTR, Omemo, PGP and even xsalsa20 or blowfish.

Details are explained here: https://bugs.unrealircd.org/view.php?id=5100

Perhaps a module could be done in order to start testing this idea and then take it to the next level.

A practical example of what I am proposing can be used with calyxinstitute.org jabber server.
Constructive criticism leads to evolution and progress. Negative criticism leads to obsolescence. We should not be living in 1990s irc management & developing standards just because it was cool.

Post Reply