listrestrict not compatible with unreal6

Looking for a module? Or want to see one converted to 6.x?

Moderator: Supporters

Post Reply
CrazyCat
Posts: 165
Joined: Thu Apr 28, 2005 1:05 pm
Location: France
Contact:

listrestrict not compatible with unreal6

Post by CrazyCat »

On one of my servers (not the same than the libcurl trouble), I tried to upgrade unreal5 to unreal6, I got compilation errors for listrestrict:

Code: Select all

make[5]: *** [Makefile:46: custommodule] Error 1
make[5]: Leaving directory '/home/zeolia/unrealircd-6.0.0/src/modules/third'
*****
Building 3rd party module listrestrict failed.
Contact the module author of the listrestrict module (not the UnrealIRCd team), or simply delete the /home/zeolia/unrealircd-6.0.0/src/modules/third/listrestrict.c file
*****
make[4]: *** [Makefile:43: build] Error 1
make[4]: Leaving directory '/home/zeolia/unrealircd-6.0.0/src/modules/third'
make[3]: *** [Makefile:97: build] Error 2
make[3]: Leaving directory '/home/zeolia/unrealircd-6.0.0/src/modules'
make[2]: *** [Makefile:77: mods] Error 2
make[2]: Leaving directory '/home/zeolia/unrealircd-6.0.0/src'
make[1]: *** [Makefile:66: build] Error 2
make[1]: Leaving directory '/home/zeolia/unrealircd-6.0.0/src'
make: *** [Makefile:141: build] Error 2
ERROR: 'make' failed
Gottem
UnrealIRCd coder
Posts: 190
Joined: Fri Aug 19, 2016 5:26 pm
Location: NL

Re: listrestrict not compatible with unreal6

Post by Gottem »

That's because the module isn't even compatible with Unreal 6 yet. U6 has barely been out for a few weeks and you can't really expect all modules to be updated immediately (especially during holiday season). Plus I have quite a bit of modules and there are a lot of necessary changes. I've been working on them but it will take some more time.

Listrestrict is also not listed under the v6 tab on the modules information page (as well as the rest of my modules) and Syzop mentioned in all the relevant docs/announcements that modules require an update to be compatible, so you could've already known it isn't yet supported for the latest Unreal (before even trying to upgrade). So simply either don't load the module for the time being, or wait with upgrading to Unreal 6 until I've updated everything.
If you like my modules, pls consider donating (through PayPal) or use the custom job fee option in my shop if you want to donate with credit card or iDEAL ;];]
CrazyCat
Posts: 165
Joined: Thu Apr 28, 2005 1:05 pm
Location: France
Contact:

Re: listrestrict not compatible with unreal6

Post by CrazyCat »

Sounds logical :)
BTW, I'll note for next upgrade to first disable plugins then upgrade :)
Post Reply