Page 1 of 1

Unreal 6.0.0 can't link (spkifp mismatch)

Posted: Tue Dec 28, 2021 4:06 pm
by CrazyCat
Hi there,

My servers were working well together when using unreal5.2.2

I upgraded them and now they start but can't link:

Code: Select all

link.LINK_DENIED_AUTH_FAILED error: Link with server serv1.zeolia.net@X.X.X.X denied: Authentication failed: spkifp mismatch
My link block are correct, I did ./unrealircd spkifp on each server and checked that it's ok. The spkifp are the same (the servers shares the same certificates), I can't understand what happen.

Any idea to help me ?

Re: Unreal 6.0.0 can't link (spkifp mismatch)

Posted: Tue Dec 28, 2021 4:58 pm
by CrazyCat
Ok, found. I don't edit my previous post but prefer to answer to had visibility to this solution:
The ./unrealircd spkifp command use conf/tls/server.cert.pem and conf/tls/server.key.pem, it doesn't care of your tls settings in unrealircd.conf.

So, if you use let's encrypt, you have to copy and rename certs to have the correct signature.

Re: Unreal 6.0.0 can't link (spkifp mismatch)

Posted: Fri Jan 07, 2022 4:26 pm
by Syzop
Just in case anyone reads this thread: UnrealIRCd 6.0.1 was released a few days later, it includes a warning about the default location being used and also prints some usage information, since you can just run ./unrealircd spkifp /path/to/cert/file

Re: Unreal 6.0.0 can't link (spkifp mismatch)

Posted: Sat Jan 08, 2022 2:38 pm
by CrazyCat
Excellent idea to add the warning.

Re: Unreal 6.0.0 can't link (spkifp mismatch)

Posted: Thu Mar 03, 2022 12:16 am
by Lord255
handled in https://github.com/unrealircd/unrealirc ... 5f0dad9dfd ? i guess. :)
(mark as solved?)