Unreal 5.0.6 Anope services cannot connect

If your UnrealIRCd is up and running but you have a question about it, then use this forum.
(NOT for installation or connecting issues! Use the other forum instead.)

Moderator: Supporters

Locked
s7ntax
Posts: 6
Joined: Tue Aug 04, 2020 10:23 pm

Unreal 5.0.6 Anope services cannot connect

Post by s7ntax » Mon Aug 10, 2020 8:26 pm

I upgraded unreal 4 to 5.0.6, setup tls and i can connect as a user using tls. However services (anope 2.0.7) cannot connect using tls and i cannot connect services without tls in unreal 5.

Code: Select all

# ./anoperc start
Starting Anope
Anope 2.0.7, build #4, compiled 11:29:42 Aug 10 2020
Using configuration file conf/services.conf
Attempting to connect to uplink #1 127.0.0.1 (127.0.0.1), port 6900
Successfully connected to uplink #1 127.0.0.1:6900
Lost connection from uplink #1 (127.0.0.1:6900): Connection reset by peer

Unfortunately it seems Anope did not start successfully
This error has been logged in your Anope Log file
Located in /home/ircadmin/services/logs/
This may help you diagnose the problem
Further help may be available from https://www.anope.org/
There is nothing in /home/ircadmin/services/logs/

My uplink in services.conf is

Code: Select all

uplink
{       
        /*
         * The IP or hostname of the IRC server you wish to connect Services to.
         * Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
         *
         * NOTE: On some shell providers, this will not be an option.
         */
        host = "127.0.0.1"

        /*
         * Enable if Services should connect using IPv6.
         */
        ipv6 = no

        /*
         * Enable if Services should connect using SSL.
         * You must have an SSL module loaded for this to work.
         */
        ssl = yes

        /*
         * The port to connect to.
         * The IRCd *MUST* be configured to listen on this port, and to accept
         * server connections.
         *
         * Refer to your IRCd documentation for how this is to be done.
         */
        port = 6900

        /*
         * The password to send to the IRC server for authentication.
         * This must match the link block on your IRCd.
         *
         * Refer to your IRCd documentation for more information on link blocks.
         */
        password = "*******************************"
}
My link block in unrealircd.conf is

Code: Select all

link services.arpradio.com
{
        incoming {
                mask *;
        };

        outgoing {
                bind-ip 127.0.0.1; /* or explicitly an IP */
                hostname services.arpradio.com;
                port 6900;
                options { tls; };
        };

        password "************************************"; /* SSL fingerprint of other server */

        class servers;
};

/* U-lines give other servers (even) more power/commands.
 * If you use services you must add them here.
 * NEVER put the name of a (normal) UnrealIRCd server here!!!
 * ( If you wonder what Services are then see
 *   https://www.unrealircd.org/docs/Services )
 */
ulines {
        services.arpradio.com;
};
I have built anope with the extra module m_ssl_openssl.cpp

Lord255
Posts: 46
Joined: Sat Feb 29, 2020 12:58 am
Location: offline

Re: Unreal 5.0.6 Anope services cannot connect

Post by Lord255 » Mon Aug 10, 2020 10:16 pm

1st:
remove ssl and tls and connect without that.
for localhost you don't need tls/ssl.

2nd:
incoming { mask 127.0.0.1; };

3rd:
/* bind-ip *; */
hostname 127.0.0.1;

4th: use same password

---
btw in case you still cannot connect them, paste your listen block too. :)

s7ntax
Posts: 6
Joined: Tue Aug 04, 2020 10:23 pm

Re: Unreal 5.0.6 Anope services cannot connect

Post by s7ntax » Tue Aug 11, 2020 6:31 pm

OK I tried all that and now I'm getting a different error.

Code: Select all

# ./anoperc start
Starting Anope
Anope 2.0.7, build #4, compiled 11:29:42 Aug 10 2020
Using configuration file conf/services.conf
Attempting to connect to uplink #1 127.0.0.1 (127.0.0.1), port 6900
Successfully connected to uplink #1 127.0.0.1:6900
ERROR: Link 'services.arpradio.com' denied (Authentication failed) [@127.0.0.1.57526]
ERROR: Closing Link: [localhost] (Link denied (Authentication failed))

Unfortunately it seems Anope did not start successfully
This error has been logged in your Anope Log file
Located in /home/ircadmin/services/logs/
This may help you diagnose the problem
Further help may be available from https://www.anope.org/
Uplink Block

Code: Select all

uplink
{
        /*
         * The IP or hostname of the IRC server you wish to connect Services to.
         * Usually, you will want to connect Services over 127.0.0.1 (aka localhost).
         *
         * NOTE: On some shell providers, this will not be an option.
         */
        host = "127.0.0.1"

        /*
         * Enable if Services should connect using IPv6.
         */
        ipv6 = no

        /*
         * Enable if Services should connect using SSL.
         * You must have an SSL module loaded for this to work.
         */
        ssl = no

        /*
         * The port to connect to.
         * The IRCd *MUST* be configured to listen on this port, and to accept
         * server connections.
         *
         * Refer to your IRCd documentation for how this is to be done.
         */
        port = 6900

        /*
         * The password to send to the IRC server for authentication.
         * This must match the link block on your IRCd.
         *
         * Refer to your IRCd documentation for more information on link blocks.
         */
        password = "**********"
}
Link block

Code: Select all

/*
 * Link blocks allow you to link multiple servers together to form a network.
 * See https://www.unrealircd.org/docs/Tutorial:_Linking_servers
 */
 link services.arpradio.com
{
        incoming {
                mask 127.0.0.1;
        };

        outgoing {
                bind-ip *; /* or explicitly an IP */
                hostname 127.0.0.1;
                port 6900;
                options {  };
        };

        password "*************"; /* SSL fingerprint of other server */

        class servers;
};
Listen Block

Code: Select all

/* Standard IRC port 6667 */
listen {
        ip *;
        port 6667;
};

/* Standard IRC SSL/TLS port 6697 */
listen {
        ip *;
        port 6697;
        options { tls; };
        tls-options {
                certificate "/etc/letsencrypt/live/irc.arpradio.com/fullchain.pem";
                key "/etc/letsencrypt/live/irc.arpradio.com/privkey.pem";
        };
};

/* Special SSL/TLS servers-only port for linking */
listen {
        ip 127.0.0.1;
        port 6900;
        options {  serversonly; };
};

/* NOTE: If you are on an IRCd shell with multiple IP's and you use
 *       the above listen { } blocks then you will likely get an
 *       'Address already in use' error and the ircd won't start.
 *       This means you MUST bind to a specific IP instead of '*' like:
 *       listen { ip 1.2.3.4; port 6667; };
 *       Of course, replace the IP with the IP that was assigned to you.
 */
In my IRC i also get the following when i try to connect services, although the passwords match in the uplink and link blocks.

Code: Select all

Link denied for 'services.arpradio.com' (Authentication failed [Bad password?]) [@127.0.0.1.57526]

s7ntax
Posts: 6
Joined: Tue Aug 04, 2020 10:23 pm

Re: Unreal 5.0.6 Anope services cannot connect

Post by s7ntax » Tue Aug 11, 2020 6:39 pm

Scratch that I fixed it, I had used the same password in the uplink block as in the link block when i should have used the password in my link services block further down in my unrealircd.conf

Thanks for the help :)

Lord255
Posts: 46
Joined: Sat Feb 29, 2020 12:58 am
Location: offline

Re: Unreal 5.0.6 Anope services cannot connect

Post by Lord255 » Tue Aug 11, 2020 10:09 pm

sure thing. nice.
(y)

Locked