error: ssl3_get_record: wrong version number.

This forum is for everyone having trouble with linking two UnrealIRCd servers

Moderator: Supporters

Post Reply
Clu
Posts: 3
Joined: Fri Oct 23, 2020 7:05 pm

error: ssl3_get_record: wrong version number.

Post by Clu » Fri Oct 23, 2020 7:15 pm

I'm trying to link two servers both inside k8s VM (ubuntu:latest) just to test this option to code my own irc server. And I got this error after using command /oper:

Unable to link with server 192.168.99.240: SSL_connect(): Internal OpenSSL error or protocol error: ssl3_get_record: wrong version number. Please verify that listen::options::ssl is enabled on port 6900 in 192.168.99.240's configuration file.

I have latest version of libssl-dev and openssl. unrealircd.conf is configured like in guide. Please can someone tell me what I am doing wrong?

k4be
Posts: 38
Joined: Sun Jan 09, 2005 12:19 pm
Location: Poland

Re: error: ssl3_get_record: wrong version number.

Post by k4be » Fri Oct 23, 2020 7:31 pm

It's likely one of three causes.
1. The one suggested to you in the error message: ssl/tls not enabled on the receiving side.
2. You're trying too often and the receiving side has throttled you.
3. The connecting side is z:lined by the receiving side.
You can check these cases by trying to connect to the s2s port of the receiving side with an irc client (non-ssl) running on the outgoing side (so it has the IP address of the outgoing side). It should output some helpful messages.

Clu
Posts: 3
Joined: Fri Oct 23, 2020 7:05 pm

Re: error: ssl3_get_record: wrong version number.

Post by Clu » Fri Oct 23, 2020 8:50 pm

Thank you for you answer!

1) I enabled ssl connections by line like in example:

Code: Select all

listen {
        ip *;
        port 6900;
        options { ssl; serversonly; }
}
2) I think that I'm trying connect not too often:

Code: Select all

class servers
{
        pingfreq 60;
        connfreq 20; /* try to connect every 15 seconds */
        maxclients 10; /* max servers */
        sendq 20M;
}
3) I didn't z-line my linking servers (if I understand what you are talking about). There is no bans, blocks or something else in unrealircd.conf.
My linking part of confing looks:
first:

Code: Select all

ink myircserver2.ru
{
        incoming {
                mask *;
        }
        outgoing {
                bind-ip *;
                hostname 192.168.99.241;
                port 6900;
                options { ssl; }
        }
        password "Ij0HE1WCLkrXncy0zZCKwmS3NduK4EsvUkumPt8JKk0=" { spkifp; }
        hub *;
        class servers;
}
second:

Code: Select all

link myircserver1.ru
{
        incoming {
                mask *;
        }
        outgoing {
                bind-ip *; 
                hostname 192.168.99.240;
                port 6900;
                options { ssl; autoconnect; }
        }
        password "rhibvyW0VqMhAmbjQQHHiJ60/WMvpfrdtNG2/VR3wW0=" { spkifp; }
        class servers;
}

Syzop
UnrealIRCd head coder
Posts: 1957
Joined: Sat Mar 06, 2004 8:57 pm
Location: .nl
Contact:

Re: error: ssl3_get_record: wrong version number.

Post by Syzop » Sat Oct 24, 2020 6:39 am

Glancing quickly at your configuration, it looks fine to me. k4be is right about the various possibilities of what could be wrong.

Did you rehash the server after making any configuration changes? And, when you do /REHASH, do you see any warnings or errors with regards to the configuration file? Naturally check that on both servers.
Just saying, as you wouldn't be the first who has a correct looking configuration snippet but forgot to rehash or did not notice that there are fatal errors elsewhere.

We also highly recommend to connect as IRCOp on both sides of the link (as mentioned in Troubleshooting: linking servers at the top). This may give you more information than you will otherwise see. Although, maybe not in this case, it is still worth a try.

Which UnrealIRCd version do you use on both?

Clu
Posts: 3
Joined: Fri Oct 23, 2020 7:05 pm

Re: error: ssl3_get_record: wrong version number.

Post by Clu » Sat Oct 24, 2020 9:18 am

Thank all for replies!
I used "unrealircd restart" command instead of /REHASH.
The problem was that bobsmith operator is already exist on someone server. After rage typing /REHASH several times another error message has appeared: "-myircserver2.ru- Nick collision on bobsmith (bobsmith 1603530467 <- myircserver1.ru 1603530267)".
It's all bobsmith! :D
So, now, it seems good when I typing /MAP:
[12:10] [006] bobsmith myircserver2.ru (1) 002
[12:10] [006] bobsmith `-myircserver1.ru (1) 001
[12:10] [007] bobsmith End of /MAP

Post Reply